MENSAGEM:
[COTC_E00044] O parceiro escolhido não possui um contato habilitado para responder cotações no portal, por isso só é permitido coleta manual.
CAUSA:
Mensagem apresentada quando o fornecedor não possui um contato marcado para "Envia notificações de cotação?" e a coleta de preço foi definida como 'Online'.
SOLUÇÃO:
Verifique na tela "Cotação" (Caminho de acesso: Cotação » Rotinas » Cotação), as configurações abaixo:
Coleta de preço: este campo representa a forma de coleta do preço do produto cotado; o mesmo pode possuir dois valores:
- Online: o fornecedor possuirá esta definição quando um contato ativo cadastrado do fornecedor possuir a marcação "Envia notificações de cotação?" realizada;
- Manual: o fornecedor possuirá esta marcação quando suas configurações forem opostas às citadas acima para o valor "Online".
O campo "Coleta de preço" não pode ser editado pelo comprador, porém, quando o comprador coletar manualmente o preço de um fornecedor que possui a coleta online, automaticamente o campo será modificado para "Manual".
Nota:
- Se a cotação possui um contato associado, e este possui permissão para receber a notificação da cotação, então o envio será realizado para este contato. Se este não possui permissão, então nenhum contato recebe o e-mail.
- Se não houver contato associado à cotação, então pegamos o 'contato padrão para cotação' do parceiro (Aba Geral >> Contato padrão para cotação), se este possui permissão para receber a notificação da cotação, então apenas ele recebe o e-mail com a cotação. Caso ele não possua permissão, então nenhum contato recebe o e-mail.
- Se não houver contato associado à cotação, e o parceiro não possui contato padrão para cotação, então pegamos o primeiro contato do parceiro configurado para receber e-mail de cotação.
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