SITUAÇÃO
Durante o cadastro ou alteração de usuários no sistema, pode ocorrer a seguinte mensagem de erro:
“É obrigatório o preenchimento de um Email no campo Sankhya ID do usuário.”
Entretanto, o campo “Sankhya ID” não é exibido na tela, impossibilitando o preenchimento da informação exigida pelo sistema. Esse cenário normalmente ocorre quando o ambiente exige a vinculação de Sankhya ID, mas o parâmetro responsável por habilitar esse campo ainda não está ativado.
CAUSA
Esse comportamento ocorre em ambientes SaaS Cloud que utilizam a BIA, onde é obrigatório que cada usuário possua um Sankhya ID vinculado.
O Sankhya ID é utilizado para autenticação e integração com serviços da plataforma Sankhya. Quando o sistema exige esse vínculo, mas o parâmetro que habilita a funcionalidade não está ativo, o sistema passa a exigir o preenchimento do campo, porém o campo não aparece na tela de cadastro de usuários.
SOLUÇÃO
Para disponibilizar o campo ''Sankhya ID'' no cadastro de usuários, é necessário habilitar o parâmetro responsável pela funcionalidade.
Acesse a tela ''Preferências'' (Configurações » Avançado » Preferências).
Busque e pesquise o parâmetro ''HABILITAACCOUNT - Habilita Sankhya ID''.
Habilite o parâmetro.
Após habilitar o parâmetro, realize as seguintes ações:
Limpe o cache do navegador
Limpe o cache do servidor
Realize novo login no sistema.
Acesse novamente a tela ''Usuários'' (Configurações » Controle de Acesso » Usuários).
Clique no botão da engrenagem (configuração de campos) e procure pelo campo ''Sankhya ID''
Habilite sua exibição.
Após habilitar o parâmetro ''HABILITAACCOUNT'' e atualizar os caches do ambiente:
O campo ''Sankhya ID'' ficará disponível no cadastro de usuários;
Será possível informar o e-mail vinculado ao Sankhya ID;
O erro deixará de ocorrer ao salvar ou alterar o usuário.
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