MENSAGEM:
[COTC_E00047]: Apenas fornecedores com situação diferente de 'Respondida', 'Aprovada', 'Reprovada' e 'Faturada' podem ser excluídos da cotação.
CAUSA:
Ocorre ao tentar excluir uma cotação que ainda não foi respondida, aprovada, rejeitada ou faturada.
SOLUÇÃO:
Nesse caso, identifique quais são as possíveis situações de um fornecedor na cotação. Em seguida, verifique se a situação do fornecedor é diferente.
Por exemplo, suponha que as possíveis situações de um fornecedor sejam 'Respondida', 'Aprovada', 'Reprovada', 'Faturada', 'Cancelada' e 'Pendente'. Com base no seu requisito, exclua os fornecedores com situações diferentes de 'Respondida', 'Aprovada', 'Reprovada' e 'Faturada'. Isso significa que os fornecedores com as situações 'Cancelada' e 'Pendente' seriam excluídos da cotação.
Em resumo, para excluir fornecedores de uma cotação com base no status de sua situação, identifique as possíveis situações de um fornecedor e verifique se a situação está dentro das situações permitidas. Se a situação do fornecedor estiver fora das situações permitidas, ele poderá ser excluído da cotação.
Para mais informações acesse o artigo de Cotação: Cotação – Sankhya Gestão de Negócios
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